Mechanics

MODELS IGNITION PROBLEM

1990 Suzuki Other

Engine Performance problem
1990 Other Suzuki Models 4 cyl Four Wheel Drive Manual 24000 miles

I have a 1990 suzuki samurai with a 1.3l F.I. Engine upon leaving work one day it just cranked and cranked without firing. Eventually it did fire and then in about 5 sec it cut out the CEL was on and it had a code 41= igniton signal. While looking at a wiring diagram I noticed that my coil had been wired backwards by the previous owner I rewired the coil and it started and it ran fine back to my home which was about 20 miles away the next morning it did the same thing with the same code but now its seems less severe and only cuts out on occasion. I do not belive it is a wiring problem beacuse if it is running you can move all the wires and it will not cut out. I figured that it had fried the coil which I replaced but it is still doing it also I have recently replaced the ecm due to a short in the tps circuit in the old computer I did buy a used ecm however but I belive that it is good. I am leaning towards the ignitor or ignition control module but it is over 300 dollars. Any input would be appreciated
Avatar
Autoguy24
September 1, 2008.



Code 41 flow chart


http://www.2carpros.com/forum/automotive_pictures/12900_ig1_1.jpg




http://www.2carpros.com/forum/automotive_pictures/12900_ig2_1.jpg


Rasmataz
Sep 1, 2008.
Thanks for the input but im have problems reading it and I cant read all of the information on the left a better pic or link would be apreciated thanks

Tiny
Autoguy24
Sep 1, 2008.
Sorry-this is the best I could do-if I enlarge it -it'll be unreadable.

Test the coil/suppressor/coupler connection-if okay bring the ignitor in and get it tested.

Rasmataz
Sep 1, 2008.
Yea all the voltages tested ok its gonna have to be the ignitor it says it might also be the noise supressor to but the car will actually run without that on there so im gonna say ignitor

Tiny
Autoguy24
Sep 1, 2008.
I was wondering if u had a picture on how to test the ignitor I do have a chiltons manual with a test procedure for a ignitor but its only showing 3 wires when mine has 4 so I dont think it is correct I belive the one there are showing me is for a 1.6 liter

Tiny
Autoguy24
Sep 1, 2008.