Mechanics

ELECTRICAL PROBLEMS

2003 Subaru Outback

Electrical problem
2003 Subaru Outback 4 cyl All Wheel Drive Automatic 54000 miles

I have alot of problems, 1) the rear wheels do not work, they roll but do not spin, is this a fuse problem? Can I get a fuse diagram to tell me which fuse does what?
2) the clucter panel (where the tach is) does not work, miles dont count, tach doesnt work and speedo does not work, no lights turn on, just clock shows up and displays the mileage, again, is it a fuse problem?
3) is there a way to test to see if the alternator is bad?
If you guys can help me out, it would be great, I dont know what to do, please help! Thank you.
Avatar
Bruce_1788
December 27, 2008.




Here is an updated list of problems, I have solved some of them,

1) the outside temp is not working, its the thing that displays the temp right below the clock and all it says is just " --" so I am wondering its a sensor issue.

2) there is a check engine light that is on, any ideas? Would a shop be able to read it for free?

3) the security light keeps flashing even when you drive. Is that normal? How do I turn it off?

4) the drivers side back window has a defroster but the pass side does not have a defroster, is that normal?

5) the mileage and the clock do not diasappear when the car is off and locked. Do they stay on all the time?

Thanks for any input.

Tiny
Bruce_1788
Dec 27, 2008.
I have a 2003 Outback with similar problem. Mileage, Trip OD and Clock all stay on when car is off and key is not in ignition. Are these supposed to stay on?
AD

Tiny
Woodcrvr
Jun 13, 2012.

AD