Mechanics

GYRO

Subaru Other

I HAVE A GYROPLANE WITH A SUBARU ENGINE. IT WORKS WELL IF IT IDLING, WHEN I TAKE OF AN USE ALL THE POWER, THE TEMP IS OK. WHEN I SLOW DOWN TO START CRUSSING IT STARTS GETIN A LITTLE HOT AND WHEN I'M READY TO LAND, THEN IT GOES UP ALL THE WAY.
IN THIS CONFIGURATION I DO NOT USE FANS, SINCE THE PROPELLER IS JUST BEFORE THE RADIATOR AND IT COLLS IT DOWN.

IT ALL STARTED WHEN I CHANGE THE ENGINE FROM A 2.2 L SUBARU IMPREZA ENGINE CARBURATED SINCE THE KIT CAME THAT WAY. TO A 2.2L ENGINE WITH FUEL INJECTION ON IT. THATS WHEN IT STARTED TO OVERHEAT. I OPEN THE HOUSES AND FOUND A PICE OF CLODE THAT WAS THERE SO IN THE TRANSPORTATION DIRT WOULD NOT GET INTO THE ENGINE. I TOOK THE CLODE OFF, AND REINSTAL EVERY THING BACK. BUT THE OVERHEATING CONTINUED. I CHANGE ALL THE ANTIFREEZE, WITH NO REULTS. I CHECKED THE TIMING BELTS. IT WAS WRITE, I CHANGE THE WATER PUMP, NO RESULT, CHANGE THE SENDER, NOTHING, CHANGE THE SENDER AND THE METER, NOTHING, CHANGE THE RADIATOR, NOTHING.

THEN I GOT A 2.5L. FROM A FORSTER 2005 AND CHANGE THE ENGINE AGAIN. I DID THIS TO INPROVE THE PWER AND ALSO THOUGHT THAT THE PROBLEM WAS THE ENGINE AND THE THAT WAS GOING TO SOLVE THIS PROBLEM. BUT IT DID NOT. NOW THAT I HAVE CHANGE EVERYTHING AND STILL DOES THE SAME. I THINK THAT THE ONLY THING THAT I HAVE NOT CHANGE IS THE HEATER CABIN RADIATOR.
DO YOU THINK THIS COULD BE THE CUASE OF THE PROBLEM?
THANK YOU
Avatar
ADG
August 30, 2007.




Check out the related content below while we wait for the question to be answered by a professional mechanic.


AD