Mechanics

SATURN SL2 BODY PROBLEM

2001 Saturn SL2

Transmission problem
2001 Saturn SL2 4 cyl Front Wheel Drive Automatic 125000 miles

I put a new valve body in my tranny because it was slamming in reverse and now that I have the new valve body in now I do not have reverse and drive. When I try starting the car it will not start in park only neutral what am I doing wrong?
Avatar
Tmaxx698
April 22, 2010.



When u put the valve body on did u hook the shifter linkage back up to the valve body?Let me know.

Saturntech9
Apr 22, 2010.
No we forgot to hook it up but we have another issue. When I pulled the new valve body back off and noticed that the shifter linkage was not hooked up I inspected the body and noticed that on the back side of the valve body there is a plunger that had almost fell out and when I checked the old one and it was spring loaded. Is it supposed to be spring loaded?

Tiny
Tmaxx698
Apr 22, 2010.
That's what I figured u forgot to hook up the linkage. Can u please post a pic of this plunger so I can see exactly what ur talking about thanks.

Saturntech9
Apr 22, 2010.
I'm sorry but I don't have access to a camera at this time I appolagize

Tiny
Tmaxx698
Apr 22, 2010.
Heres a exploded view of the valve body and transmission see if u see that part in the diagram if u do let me know what number it is.


http://www.2carpros.com/forum/automotive_pictures/416332_2001_transmission_exploded_view_1.jpg


Saturntech9
Apr 23, 2010.
Changed erg valve, transmission valve body, fluid, and filter. And still hard shifting in all gears. 2001 SL2. No engine lights on. And ideas? Does TCM reboot itself?

Tiny
Bweymer
May 27, 2012.