Mechanics

JUMPING IDLE AND CHECK ENGINE LIGHT ON

SAAB Other

I have been having issues with my 96 saab 900se turbo auto. It seems to occur mostly on humid days. The idle will jump up and go back down multiple times and the car will surge as it coasts when I let off the gas pedal going down the road. It almost feels like the cruise control kicks in because it takes a long time for the car to coast to a lower speed after I let off the accelerator due to the surging. I also detect a rotten egg smell coming from the exhaust when this problem occurs. The check engine light is on and I scanned it with my friend auto x-ray system. The codes read a malfunction in the #1 o2 sensor, no activity in the #2 o2 sensor, and lean mixture. The codes are p0130, p0140, and p0171. I already replaced the front o2, cleaned the idle air control valve, changed vacuum lines, and m.A.P. Sensor. When I had the auto x-ray connected I monitored the activity of various components with the engine running. The rear o2 showed voltage activity so I dont understand the code stating it had no activity. The front showed activity as well but when I pushed on the accelerator to rev the engine both o2's dropped to zero volts for a split second. Im not sure if that is normal. I noticed when I changed the vacuum line going to the fuel pressure regulator I detected a fuel odor inside of it. I also noticed that my fuel guage reading will drop quickly when this problem occurs. Tonight I was at a quarter tank of gas when the idle/surge issues started and only drove 5 miles or so before it quickly dropped to less than an 8th tank. Any advice would be greatly appreciated. Thanks
Avatar
Mach1_70
June 8, 2006.



Check out the related content below while we wait for the question to be answered by a professional mechanic.