Mechanics

980S-1990S CHRYSLER COMPUTER CODES

1993 Plymouth Voyager

1993 Plymouth Voyager

* Start with the ignition off. Within five seconds, switch the key on, off, on, off, on. (On is *not* start!)
* The "check engine" light will flash. Count the flashes Each code is a two digit code, so a (for example) 23 would be FLASH FLASH (pause) FLASH FLASH FLASH (loong pause)
* It will never flash more than 9 times, watch for pauses!
* 55 is end of codes - it's normal. Before you call your dealer or mechanic, consider that the blink-spacing is not always perfectly uniform, so if you see 23 23, it's probably just a single 55. (Codes are not repeated.)
* 33 is normal on earlier models if you don't have air conditioning.
o John McGuire wrote: "The older Vipers will blink out diag codes with four off/on key turns. They removed the capability starting in... I think 2000, at any rate I know my 2001 requires a computer to check the codes."
* On some models (such as a 1995 Neon), when the check engine light goes on, you may be able to get the codes simply by putting in the key and moving it to the RUN position; the light will blink out the codes by itself.
* Please note that some codes are NOT included below, this is not a complete listing, but it IS very close to complete. It stemps from a list posted on the Mopar Mailing List, but many modifications have been made.
* * Activates Power Limited/Check Engine light on some models.

IMPORTANT. Codes may be different for newer vehicles starting in the late 1990s. See the earlier section.

* 11 No ignition reference signal detected during cranking (bad Hall effect) OR loss of camshaft sensor (and, for cars with crankshaft sensors — which does not include the 2.2/2.5 — timing belt skipped a tooth or loss of crankshaft sensor). See note #8 below.
* 12 Battery or computer recently disconnected (will occur on most cars most of the time, it indicates a low / missing battery happened in the last 50 key starts. Don't worry about it. — Tom Wand)
* 13* MAP sensor or vacuum line may not be working
* 14* MAP sensor voltage below .16V or over 4.96V
* 15 No speed/distance sensor signal
* 16* Loss of battery voltage detected with engine running
* 17 Engine stays cool too long (bad thermostat or coolant sensor?)
o 17 (1985 turbo only): knock sensor circuit
* 21 Oxygen sensor signal doesn't change (stays at 4.3-4.5V). Probably bad oxygen sensor
* 22* Coolant sensor signal out of range - May have been disconnected to set timing
* 23* Incoming air temperature sensor may be bad
* 24* Throttle position sensor over 4.96V (SEE NOTE #3)
* 25 Automatic Idle Speed (AIS) motor driver circuit shorted or target idle not reached, vacuum leak found
* 26 Peak injector circuit voltage has not been reached (need to check computer signals, voltage reg, injectors) (SEE NOTE #4 BELOW)
* 27 Injector circuit isn't switching when it's told to (TBI)
OR (MPI) injector circuit #1 not switching right
OR (turbo) injector circuit #2 not switching right
OR (all 1990-) injector output driver not responding
- check computer, connections
* 31 Bad evaporator purge solenoid circuit or driver
* 32 (1984 only) power loss/limited lamp or circuit
* 32 EGR gases not working (1988) - check vacuum, valve
* 32 (1990-92, all but Turbo) computer didn't see change in air/'fuel ratio when EGR activated - check valve, vacuum lines, and EGR electrical
* 33 Air conditioning clutch relay circuit open or shorted (may be in the wide-open-throttle cutoff circuit)
* 34 (1984-86) EGR solenoid circuit shorted or open
* 34 (1987-1991) speed control shorted or open
* 35 Cooling fan relay circuit open or shorted
* 35 (trucks) idle switch motor fault - check connections
* 36 (turbo) Wastegate control circuit open or shorted
* 36 (3.9/5.2 RWD) solenoid coil circuit (air switching)
* 36 (Turbo IV) #3 Vent Solenoid open/short
* 37 Shift indicator light failure, 5-speed
OR
part throttle lock/unlock solenoid driver circuit (87-89)
OR
solenoid coil circuit (85-89 Turbo I-IV)
OR
Trans temperature sensor voltage low (1995 and on; see NOTE 2)
* 41* Alternator field control circuit open or shorted
* 42 Automatic shutdown relay circuit open or shorted
* 42 Fuel pump relay control circuit
* 42 Fuel level unit - no change over miles
OR
* 42 Z1 voltage missing when autoshutdown circuit energized (SEE NOTE #6)
* 43 Peak primary coil current not achieved with max dwell time
OR
* 43 Cylinder misfire
OR
* 43 Problem in power module to logic module interface
* 44 No FJ2 voltage present at logic board
OR
* 44 Logic module self-diagnostics indicate problem
OR
* 44 Battery temperature out of range (see Note #1!)
* 45 Turbo boost limit exceeded (engine was shut down by logic module)
* 46* Battery voltage too high during charging or charging system voltage too low
* 47 Battery voltage too low and alternator output too low
* 51 Oxygen sensor stuck at lean position (Bob Lincoln wrote: may be tripped by a bad MAP sensor system causing a rich condition, and the O2 sensor trying to compensate. The O2 sensor may still be good. The MAP assembly consists of two pieces, the valve and the vacuum transducer (round plastic unit with cylinder on top and both electrical and vacuum connections) - If you get hot rough idle and stalling, especially on deceleration, accompanied by flooded engine and difficulty restarting, that can be a bad MAP sensor causing the O2 sensor to try to compensate. If you get poor cold driveability, stumbling and bucking, and acceptable warm driving with poor gas mileage (a drop of 10 mpg or more), that is usually the O2 sensor. [Webmaster note: MAP sensors seem to die regularly.]

OR

* 51 Internal logic module fault ('84 turbo only).
* 52 Oxygen sensor stuck at rich position (SEE NOTE #5!)
OR
* 52 Internal logic module fault ('84 turbo only)
* 53 Logic module internal problem
* 54 No sync pickup signal during engine rotation (turbo only)
OR
* 54 Internal logic module fault ('84 turbo only) - or camshaft sensor/distributor timing (7)
* 55 End of codes
* 61 "Baro" sensor open or shorted
* 62 EMR mileage cannot be stored in EEPROM
* 62 PCM failure SRI mile not stored
* 63 Controller cannot write to EEPROM
* 64 Catalytic converter efficiency failure
* 65 Power steering switch failure

* 88 Start of test (not usually given, don't expect it)

Footnotes
NOTE #1.

The power module has an air-cooled resistor which senses incoming air temperature. The logic modules uses this information to control the field current in the alternator. This code applies ONLY to alternators whose voltage is computer regulated. If you lose the feed to keep RAM information stored when the engine's off, you also lose battery voltage sensing. -- Bohdan Bodnar
NOTE #2.

From the 1995 TRUCK manuals: the trailer towing package includes a transmission coolant temp sensor while the standard package doesn't. This may cause the low (no) voltage indication. -- J.E. Winburn
NOTE #3.

Matt Rowe: “The throttle postion circuit tells the computer how far the accelerator is depressed. The Throttle Position Sensor (TPS) is on the throttle body on the opposite side of the throttle cable. The connector should have a round rubber cover over the connections. Clear the fault codes, start the car and try jiggling the wires/connectors to try to trip a fault code. Loss of this signal could cause other problems.”

Tom Wand: “Throttle Position Sensors (TPS) will on some early 1990s trucks start to drift high in voltage, there was a problem with these and the idle will not set low enough. Need to replace if it does this. As I recall, the output voltage at idle is 2.4 volts, much above is no good.”
NOTE #4.

During cranking, the computer will test the current through the injector to see whether there's too much resistance in the injector's path. If there is, code 26 is set.

The problem may be cured with tuner cleaner on the connectors.

For TBI engines, the injector's cold resistance should be between 0.9 and 1.2 ohms (specs vary with year). This is a peak-and-hold injector. With the engine idling the peak period should be about 1.2 milliseconds whereas the hold period will vary. If it's lower than this at idle, then the injector's shorted or there's a defect in the injector driver circuit. (Bohdan Bodnar)
NOTE #5.

Wade Goldman wrote: In my case, the breather tube leading into the catalytic converter had rusted and become detached. This some how would cause the sensor to read an over rich condition and run crummy. I did not trust the reliability of the weld over a corroded surface and opted for the more expensive route of replacing the converter, breather tube and all.
NOTE #6.

The Z1 voltage is the voltage of the circuits fed by the autoshutdown relay. This typically includes fuel pump and switched-battery feed to the ignition coil(s). In my Le Baron, the Z1 circuit leaves the power module and splits into two paths: the fuel pump and the positive side of the ignition coil. Internal to the power module is the auto shutdown relay (in my case, it's a sealed box about 1" by 1"). The output voltage is monitored to determine whether the relay responds correctly. I suspect that the ASD relay (and, therefore, the Z1 circuit) also feeds the fuel injector(s) driver(s) and current sensing circuit, but can't prove this.

I've used the Z1 voltage to test for good power connections to the power module. I connected my OTC 500 multimeter from the battery's positive post to the ignition coil's switched battery terminal and measured the voltage drop using the bar graph to monitor peak voltages. Voltage spikes of around 200 mV to 300 mV are ok -- anything more means tv tuner cleaner time (or replacing the power module). Another thing to check is the maximum voltage drop during the priming pulse. With the old power module, I was losing about 2 volts across the circuit; the replacement is losing about 1/4 volt. (Thanks, Bohdan Bodnar)

Unconfirmed correction: The Z1 Circuit is used to feed the engine computer; if it is lost, the delayed turnoff will not occur, and restarting will not go well. I forget but think it is the engine flair (speed flair up upon starting) that is lost. It also feeds the injectors and solenoids and other relays. (Thanks, Tom Wand)
Note #7

Steve Knickerbocker wrote: Inside your distributor you have two pickups, one is for the ignition and one is to tell the computer where number one cylinder is in its rotation. If you look at the four slotted tangs inside there you will see one has a bigger slot, that's the one that tells the sync pickup what's number one. In other words, the pickup inside the distributor is bad.
Note #8

Can cause the engine to stop working entirely with no limp-home mode. Note: An anonymous poster wrote, “Code 11 will only be set upon clearing the codes, most commonly by disconnecting the battery. It says in the factory diagnostic manuals that code 11 means no ignition reference signal has been seen since battery disconnect. As soon as the vehicle's engine is cranked, and a reference signal is seen, code 11 will go away immediately on it's own. It also won't be set upon failure of a part such as a hall-effect pick-up plate, or loss of the timing belt. If no reference signal is seen during cranking after a battery disconnect, code 11 will remain. This is a helpful indicator in a no-start condition.” (Chrysler did sometimes change codes depending on the year, so it may be that some of these apply to differentyears.)

Here is the url..http://www.allpar.com/fix/80s-codes.html
Avatar
Zebotw
August 24, 2008.



Check out the related content below while we wait for the question to be answered by a professional mechanic.