Mechanics

MODELS 88 OLDS CUTLASS CALAIS INTERNAT

1988 Oldsmobile Other

Engine Mechanical problem
1988 Other Oldsmobile Models 4 cyl Front Wheel Drive Automatic 170000 miles

My car never really had any issues until recently. A couple of weeks ago I started to notice some power loss and/or stuttering during acceleration and thought that maybe I needed to get some fuel injection cleaner (of course, I never did).
A couple of days ago, I went to drop my daughter off at school and the car would barely move. When I put it in drive it would go forward, but it wouldn't go more than 10 - 15 mph and it sounded as if it wasn't getting any gas. I noticed that the gas was low and figured that was the problem. I made it to the gas station, and needless to say, that wasn't the issue. It continued to sputter all the way to the school yard.
Once I got there, I was able to start it, but every time I put it in gear it would die. I had to put it in neutral to keep it alive, then while my foot was on the gas, move it into gear. It finally died while moving and refused to restart. I had it towed home and the next day it started but died when I tried to reverse it into my parking stall.
I've been told to check the o2 sensor, but I'm not quite sure if that would cause all of this. Any suggestions? I appreciate any help that I can get, I'm tired of having to carpool to work! : )
Avatar
GelflingLady
April 23, 2009.




Check out the related content below while we wait for the question to be answered by a professional mechanic.


AD