Mechanics

INSTRUMENT PANEL

2000 Nissan Pathfinder

Interior problem
2000 Nissan Pathfinder 6 cyl Four Wheel Drive Automatic 70000 miles

I have a 2000 Nissan Pathfinder and in the last few days my instument panels has been cutting out. My speedometer, RPM gauge, battery meter and fuel gauge cut out when I drive. Sometimes it comes right back on while other times it takes a few miles.

Do I have a loose connections or would it be some sort of speed sensor?

G
Avatar
Garth5577
March 7, 2008.




I have the exact same problem although mine is a 2001.
The dealer tells me it is an instrument cluster malfunction and an electronic board needs to be replace ($500 to $800). They got a P0500 code indicating a speed sensor malfunction but since everything else on the panel brakes (i.E. Gas gauge, rpm, temp) it probably is not the speed sensor. That is the only thing the computer knows how to detect perhaps.
I was also told to check the fuses to see it is loose. I also heard something about a voltage regulator being faulty but I am not sure if there is one in the 2001 model.
Anyway it is a difficult and frustrating problem to diagnose. It does no seem common either as you are the only one I have seen on the web, and I have been searching.
If you have found anything or heard of any possible solution I would really appreciate.
Thanks and good luck!

Tiny
Frecapi
Apr 19, 2008.
We have the same problem where the instrumement cluster intermittently fails on a 2000 Pathfinder and then works the next day. Also getting code P0500 on VSS sensor periodiclly.

Just curious if you got the problem fixed and what parts they replaced to fix the problem.

Thanks

Tiny
Larry Diaz
Jul 20, 2009.
I am having a similar problem with my 98SE. I would sure like to hear your resolution as well.

Put a new battery in a week ago - alternator is charging OK - had been load checked during routine service 2 weeks ago, but suddenly died - battery was dead and wouldn't take a trickle charge. Alternator regulates to 13.8V idle and up to 14.4 at speed.

Now a couple of days later the speedo dies, followed by the tach - which actually flickers up and down - worse at low revs, then I see the fuel and temp gauges are pinned, and the odometer reads 999,999.

I have full voltage at the back of the cluster and ground is solid at 0.6 ohms.

I was thinking I need a new instrument cluster - can get a used one at a wrecker for $150 CDN- but the on line parts manuals don't seem to list one - just the individual components.

Would sure appreciate any input, or suggestions of what else I should look at.

And a question, will putting in a used cluster change my pristine PF's low mileage reading (105K miles) to the high mileage of the beater I get it from?

Tiny
Deeman
Jul 20, 2009.
I had the same problem, and replacing the instrument cluster worked for me. The only issue was the mileage is that of the vehicle it was removed from.

Tiny
Ghostofanamelessman
Nov 24, 2009.
I have the exact same problem on my 2000 Pathfinder LE. The gauge cluster dies every once in a while, and usually works fine after I shut the car off and restart after a few minutes. I think this has only occured for me during the summer. My guess would be it is something to do with a thermal sensor somewhere in the dash that protects the circuitry? That is only a guess.

Has anyone figured out how to fix this?

Tiny
Pathfinderguy13
May 24, 2010.
Pathfinder Instrument Panel
Interior problem
2000 Nissan Pathfinder 6 cyl Four Wheel Drive Automatic 70000 miles

I have a 2000 Nissan Pathfinder and in the last few days my instument panels has been cutting out. My speedometer, RPM gauge, battery meter and fuel gauge cut out when I drive. Sometimes it comes right back on while other times it takes a few miles.

This question was asked a few yars ago but I couldn't find the answer. Since I am a new owner of a 2000 pathfinder and having the same issues as above, and getting a code P0325 and P0500. I would like to know what options do I have before replacing these sensors and having the same proble.

Please respond ASAP as I'm looking into taking care of this ASAP.
Thanks
AD

Tiny
Jhosiean
May 21, 2012.
99 Pathfinder. Kind of same problem. Rpms, speed, temp, miles dies once in a while. When hot or warm wheather (good thing is that in MN we don't have much of those days). Sometimes comes back while still driving. Sometimes after suv is parked (engine shut down) for a few mins. If I change the instrument cluster (for a good one) will fix the problem?

Tiny
MNPathfinder
Jun 1, 2012.

AD