Mechanics

ABS, TCS DASH LIGHTS ON.

2002 Nissan Altima

Brakes problem
2002 Nissan Altima 6 cyl Front Wheel Drive Automatic 71000 miles

I replaced my left rear hub. Now my dash lights for ABS and TCS are on.
When I start the car the lights are off. I drive down the road and the break pedal is very firm and vibrates when pressed. I also have elactronic clicking noises coming from what sounds like behind the dash.
Shortly after driving down the road the ABS and TCS lights come on, the break pedal feals normal now and there is no vibration and the clicking behind the dash is gone.
Another problem that started with this job is, when the dash lights are out and I accelerate the car seems to die out like it suddenly is not getting fuel, but then picks up again.
I am not sure what is happening. I had not problems other than a bad rear hub before all this started.
Took car to Dealer, they put it on the computer, which in itself cost me $100.00. They say I need a new ABS sensor at the cost of about $330.00. They also tell me the hesitation problem is unrelated and may be the Crank sensor which will cost about the equivalant of 2 car payments, lets say $1100.00.
Well I was going to take a look at the sensor and in trying to remove it the head of the bolt broke off and now I have a sensor that is hanging and a stud broken off in the rear suspention housing and I can't get it out.
I could use a little help if anyone has run into the situation before.
Thanks, JimmyMac
Avatar
JimmyMacRN
December 12, 2009.



Check out the related content below while we wait for the question to be answered by a professional mechanic.