Mechanics

GLE ENGINE SPEED

1994 Nissan Altima

It happened twice.
For the first time, when I started it, at " parking " positon, the engine speed stayed at 1000-2000 r/min. After 2 min's warm up, I put the gear onto " Reverse" position, all suddenly, the engine speed went up to over 6000r/min. Then I turned off. When I tried to start it again, the engine speed remained at high speed of 6000. I had to turned it off. I tried several times, then I had to gave up. But after 30 min, I restarted it, it ran okey at parking position, like it should be. I did not try the reverse position.

A week later, it happened again. I warmed up the car for 2 min (let it running for 2 min at the parking position), and reversed out of the parking lots, and drove forward as nomal. 2 min later, I wanted to go back to pick up something, so I braked it down, stopped, and tried to turn the car back. I changed the gear onto " reverse" position. Then, the engine speed went up to more than 6000r/min again. I had no choice but turned off the car. I tried to started several time, still I didnot go back to be normal.
Then, I tried to depress the gas peddle before I started the car. After 2 times, it came back nomal.

So, anybody can tell me what is going wrong, is it because idle air controll valve?
Thanks!
AD
Avatar
Longkouwan
February 5, 2007.




Have the throttle position sensor and the idle speed control valve check. Could also be a throttle plate sticking or shaft
AD

Rasmataz
Feb 7, 2007.
Thank you very much!
Could you recommand a place where I can have it checked and fixed at a low price. I am right now in Columbus OH.

Tiny
Longkouwan
Feb 7, 2007.
Thank you very much!
Could you recommand a place where I can have it checked and fixed at a low price. I am right now in Columbus OH.[/Quote: 256fbaddbe]

Sorry, I can't recommend a place am out in the middle of the pacific ocean.

Rasmataz
Feb 7, 2007.

AD