Mechanics

ELECTRICAL SYSTEM ACTING GOOFY

1988 Mitsubishi Starion

Electrical problem
1988 Mitsubishi Starion 4 cyl Two Wheel Drive Manual 88000 miles

the car started and ran fine with brand new battery 2 months ago, battery was then removed from car and put in garage. Charged battery yesterday ( pulled 5 amps 4 2 hrs) then put it in car and starter easily turned over engine but no ignition. While the key was turned in the ignitiion the wiper blades wouldn't stop moving, the radio wouldn't work and the blower motor never stops turning and the automatic temp control doesn't light up (not working?) I started paying with the battery posts and noticed when putting the positive post back on a clicking sound comes from a relay on the fire wall (maybee Voltage regulator?) Well today I figured I would go out and look at it again.I thought I had disconected the battery but I guess I forgot. No power to car at all now, put battery on charger and it pulls over 50 amps off scale! Blows trip on charger after 30 secends and charger kicks off, it did this twice (I have expensive 2 setting charger Start 50 amps and general charge) I thought the charger had a problem but when I hooked it up to the battery in my other car it charged fine 8 amps. Whats going on here? Did the relay/vo; tage regulator on firewall fail causing goofy car electrical probs? But whats with the battery? Any help appreciated Tony
Avatar
Tldpdb1
November 23, 2009.




Check out the related content below while we wait for the question to be answered by a professional mechanic.


AD