Mechanics

IDLE CONTROL PROBLEM

Mitsubishi Other

97 mitsubishi eclipse gs-t
manual
2.0L
136k

This is my problem.
When first started (The engine is warm), the car idled around 700-800 rpm, which is fine.
However, After I'd been on the freeway for about 10 Minutes, I noticed that
the car would start to idle funny. When driving on the freeway, usually if I
take my foot of the gas, the rpm would start to drop maybe about 500 or so
from where it was, and then about 3 or more seconds, the car rpm would
completely drop to a low idle range. After getting off the freeway, I
stopped at a red light and noticed that the car idle is fairly high. Around the
1,000 - 1,200 rpm area. When put into neutral or park, it's still idle at 1,000 or so.

Now if the car is restarted, the car would idle fine at first around 700 - 800 rpm.
But would later rise to 1,000 - 1,200 rpm.


I already cleaned the idle control valve
The screw you adjust on the top of the throthle is fine to where it should be.
What I was thinking about doing next is replacing the idle control sensor, this is because while the car is running I unplug the swith to the idle control sensor and nothing happens. Natrually after you disconnect that switch the engine would idle really bad to the point where it would die, in other words you would notice a diffirence. But when I do this nothing happens and thats why I think that might be.

But if this isnt the problem then what can I do to fix it.
Avatar
Cirilo
March 31, 2007.



Check out the related content below while we wait for the question to be answered by a professional mechanic.