Mechanics

AIR CONDITION/IDLE PROBLEM

Mitsubishi Other

I have a 2002 Mitsubishi Eclipse V6 spyder. I just got the battery replaced yesterday and when I turned my a/c while driving, I noticed that when I stop in traffic, my car shakes and almost shuts off due to a low idle. The idle fluctuates up and down for a while then stops. This happens continuously when I stop again after driving with the a/c is on. Is there somthing wrong with my alternator? Did the mechanic put the wrong battery? Thanks much for the help
Avatar
Fady2002
May 3, 2007.




I'm also having the same problem. Only it didn't happen immediately after switching the battery. It happened like a week later. The car was running low RPMs and when the air was on, when I would brake, the car would stall almost everytime. It would be a mission to get it to turn on again. I initially thought it was the alternator belt. It turned out that Pep Boys sold me one that was a half inch longer than the one my 2000 Eclipse RS takes. So I replaced it myself and the car seemed to be running fine until about after a couple of milesworth of driving the car stalled on me again. I took it back to the garage and they tuned the idle on the throttlebody so that the RPMs don't go low enough to make my car stall. So far within the past few days the car has not stalled but i'm getting wierd symptoms on the car on a cold start. Normally, from what I can gather, when the car does a cold start, the RPMs go to like 2000 RPMs and then lower to idle. But what is happening to me is that when I turn on the car, it goes straight to idle RPMs and stays there. Is there a possible vacuum leak? Is there not enough gas getting to my engine? (The car takes a few cranks to start up when it's cold, anyway) or is there something wrong with the fuel to oxygen ratio? Please get back to me on this asap. Thanks

Tiny
Guitardude87
May 9, 2007.


AD