Mechanics

SPUTTERING AND STALLING

1995 Mercedes Benz S500

1995 Mercedes Benz S500 V8 Two Wheel Drive Automatic 81000 miles

Hello! I am desperate to also find the solution to the very same problem as several other members are experiencing with my 1995 Mercedes S500. This problem has been going on for 11/2 years, and $6000.00 later, no results. My car turns on, and as I put either in reverse to leave driveway, or in drive mode to go forward, the engine sputters a little then just stalls. The car cranks up again, and does the same thing again. It also occurs while actually driving at higher speed. Also, same problem when pulling up to stop sign or stop light. Car will stall out with all dash lights on. I feel very unsafe in the vehicle, as I have to sit in the road and restart. I have had vehicle to Ft. Lauderdale Mercedes Dealer here in Florida, no less then 8 times! Still no repair! Distributors, {has two of them you know!}, Fuel pump, tune-up, fuel filter, ignition harness, ignition module, fuel check valve, pump relay, all for a total of 82 days in service! The ignition module alone was $1000.00 when replaced! I'm so frustrated yet I would so much like to have my car that I originally paid $72,000.00 for just run, as I also have had it serviced and very well cared for since purchase at Mercedes dealership! Please help! Thank you all so much!
Avatar
Tominfl
August 7, 2008.




Check out the related content below while we wait for the question to be answered by a professional mechanic.


AD