Mechanics

CARBEURATOR PROBLEM

1980 Mazda RX7

Engine Performance problem
1980 Mazda RX7 Two Wheel Drive Manual 90000 miles

My RX7 has become difficult to start and (sometimes) bogs when I'm moving and step down on the accelerator. While checking, I found that the carb only dribbles a little gas into the jets when I push the accelerator. It used to squirt. Thinking it must be the accelerator pump, I installed a new one (and was able to accomplish this without removing the carb) but there was no change. I also tried running a few cans of carb cleaner through the system. Also no change. Where else should I look for the problem?
AD
Avatar
FXProglJr
January 14, 2010.



Ok what you will need to do is remove and rebuild. You need to clean out the passages. It will need to be soaked in carb dip to get the sludge to soffen up so you can use carb cleaner and air to clean the passages out so the fuel can move freely through them.

Racefan966
Jan 14, 2010.
Thanks much for the prompt response. I was afraid that's what you were going to say. Removing the carb from this car is not a simple project. But I'll give it a try as soon as it gets a bit warmer and let you know how I make out.
Frank

Tiny
FXProglJr
Jan 15, 2010.
I know it isn't but you will do fine. If you have any questions once you get there just ask ok.
AD

Racefan966
Jan 15, 2010.
Well.I finally made some time to remove and disassembled the carb. This time, I went further down into it then ever before and soaked everything. I applied carb cleaner & blew out all of the passages (I even took apart the check valves associated with the accelerator pump and cleaned up all of the parts). It's all back together now and everything seems to work fine. Thanks much for your advice. Frank

Tiny
FXProglJr
May 9, 2010.
I have rebuilt my 1980 rx7 carb, followed all the diagrams, cleaned and soaked all the parts, jets, etc. I am getting good fuel into the carb, the engine turns but won't start. I can hear that the car wants to start but it just won't fire. I have also replaced everything else, ie. Spark plugs, wires, distributor, thermostat, ect. I replaced the accelerator pump diaphragm and still nothing. What do you think?

Tiny
Cwhill
May 18, 2012.
Do you have spark?

Racefan966
Jun 19, 2012.

AD