Mechanics

ENGINE HAS POOR PERFORMANCE

1994 Lexus LS 400

Engine Performance problem
1994 Lexus LS 400 V8 Two Wheel Drive Automatic 155560 miles

I have a 94 lexus ls 400 and lately the car started performing badly. It has a lack of power, idle's very high, has a hard time starting, and when in gear the car has a hard time accelerating. I took it to a mechanic and he diagnosed it and told me I have a bad fuel pump. But before I go and get it fixed I would like a second opionion.
AD
Avatar
Lexo
August 14, 2010.




Thanks for the advice. Before we took it to the mechanic we weren't able to diagnose it ourselves so we were looked at some things. One thing that was weird was the mass air flow sensor. When we would unplug it there would be no change in the way the engine sounded. Usually if the car is running normal an you unplug the mass air flow sensor, it would start to idle high, no? We checked the spark plugs and they looked foul. They looked really black at the tips. Its also possible that my gas is bad because the day I went to go put gas, the car was driving just fine until I went to the gas station. After I put gas thats when all these problems started. I'm still working on looking at the rest of the list. The day I went to go get it diagnosed the mechanic didn't tell me much. He didn't tell me what codes appeared when he diagnosed it. I don't know how he knew it was a bad fuel pump. I'm not sure if he actually looked at the fuel pump. He also said to change the fuel filter, but we changed that part last monday. When I told him that he didn't say anything. Thanks for the advice again.

Tiny
Lexo
Aug 16, 2010.


AD