Mechanics

WONT START

2004 Kia Optima

Electrical problem
2004 Kia Optima 4 cyl Two Wheel Drive Automatic 79, XXX miles

We have a 2004 Optima that came to the shop. When received the owner said it would run for 20-30 miles then die, wouldnt restart until 4-5 hours later. We we received it we checked it out an showed to have a weak coil(figured it was heating up an quiting) so we replaced it. After it idled here in shop It was ran down the road about 2 miles down the road it quit. After we got it back to the shop it had NO fire nore is the Injectors firing. Took the timing cover off an the counter balance belt was broke. We replaced the counter balance belt, new timing belt since we was there an Crank Positioning sensor because the belt had smacked it up. But it back together have No Fire to plugs or to injectors. Got another CPS still the same thing. Also the OBD II has 12 volts coming to it but will not link. Please give me so help.
Avatar
Barkerracingservice
August 19, 2010.



Hi
Is there power to coil and injectors? Does fuel pump run ie. Fuel pressure. Scanner does it say no comm?
Let me know
Thanks for donate

Docfixit
Aug 19, 2010.
Yes there is power to the coil an to the injectors. But when I hook my noid lights to the injectors there is no pulse. Also no fire coming out of coil pacs. The fuel pump is also NOT kicking in. Have checked relay under dash with ECU. The scanner says NO COMM.

Thanks

Tiny
Barkerracingservice
Aug 19, 2010.
Does nobody have any ideas?

Tiny
Barkerracingservice
Aug 20, 2010.
With what you reported the ECM is the culprit. T belt broke because cit was not changed at 60K

Docfixit
Aug 20, 2010.
Thats what I thought to but at $970 for a new one I wanted other thoughts.

Thanks

Tiny
Barkerracingservice
Aug 20, 2010.
Could verfiy Data lines good check from Data Link TERM #7 to D9 at ecm and TERM # 19to C2 if good then NO COMM is telling ECM failure. Man KiA proud of there computer

Docfixit
Aug 20, 2010.