Mechanics

XJ SPORTS (V8 3200) HEATER WORKS ERRATICALLY

1998 Jaguar XJS

The heating fan and display works fine, but the heater itself works only occasionally, regardless of engine temp or how long it's been running. Without touching the controls it can go from blowing warm to blowing cold, no matter what temp it's set at. I bought the car at the start of last summer and have no idea if the problem existed then. During the summer I had a major overheating problem as one of the rad fans had jammed, the system actually blew a hose off. That's been rectified and the engine temp behaves normally now - I mention it just in case it may have caused the heater problem. The coolant level falls very little, I top up maybe half a litre every 3 months (guess). The aircon works fine. The car mists up very easily in wet weather and I constantly have to switch on the demist fan which also switches on the aircon and blows cold air to clear the glass.

Any pointers would be most appreciated.
Avatar
MikeC
March 19, 2007.




Might have a bad/leaking heater core.

Tiny
Jack42
Mar 19, 2007.
Thanks for the tip, but I don't think so. There's no leakage, and I've just flushed it - the flow seems fine.

I removed both valve and pump. They work great when 12v from the battery is put through them, but on the car (with heating set to top temp and fan on max) I'm getting about 6v on the valve and just a flicker on my multimeter from the pump. Is there an electronic module that controls this?

Cheers,

Mike
AD

Tiny
MikeC
Mar 20, 2007.

AD