Mechanics

BAD TRANNY

1999 Jaguar XJ8

I own a 1999 XJ8 with 71,000 miles.
I purchased this vehicle in November of 2006, the vehicle had engine problem in May of 2007.
The problem with the car was the timing chain tensioner. The car sat from May til November 2007. The vehicle was fixed in november of 2007(last week). Car was then drove from shop about 20 miles ran fine gears smooth on highway about the speeds of 70-75 mph. As exiting the highway I stopped the vehicle at a red light, then pulled off LOUD BANG IN THE REAR, then transmission fault light appears on dash. The car now drives about 15 mph, stop put the car in park then reverse, but the car is fine. Then put the vehicle back in drive and the vehicle only moves about 15 mph. Any Ideas? : Twisted:
Avatar
Jagmp
November 18, 2007.



The trans is in what the dealer calls limp home mode. Meaning the car is in 4th gear fixed only to get the car to a dealer or repair shop. You can tring disconecting the battery and see if the limp home goes away. You should take it and have the codes checked some where. It will tell you more on what is wrong with the trans. I can help more if you have codes. Hope this helps

Tiny
Fstranger302
Nov 19, 2007.
We have a 98 jag, whose tensioners broke, and warranty had to replace the engine a while ago, and then soon after, the reverse gear of the tranny also went (again, under warranty). Somehow, the 98-99 trannies's reverse gears started cracking due to a manufacturers defect. Good luck, sounds like one costly proposition.

Tiny
3tommy
Nov 20, 2007.