Mechanics

RODEO 01 60,000 WITH SIGNAL LIGHT PROBLEMS

2001 Isuzu Other

My 2001 Isuzu Rodeo with 60,000 miles recentlly started showing a solid green signal light on the dash when the headlights are turned on. When this light is on, it does not allow me to use my turnsignal on that side. However, the turn signal works fine when the headlights are not on. At the same time, the parking light (which also runs off of the same turn signal light stopped working on the opposite side). I thought ok, burned out bulb. 10 minute job. I changed the bulbs on both sides, and neither of them are working and the green light is still on. I thought it could be the fuse for the lights so I checked, and just for the sake of trying I decided to go ahead and change it, still nothing. I am at the point of pulling my hair out! My husband is a corpsman in the navy, serving in Iraq with the Marines, so I can't get help there. I know the basics, but if someone can help me, I am great at following instructions to get this problem fixed.
Avatar
Navywife
May 10, 2006.




Thank your husband for his service to this great country. Did you check the flasher unit?

Tiny
Lsussel
Jun 1, 2006.
Odd enough, about a week after all of this started, it started to work again. I tried a million things, and even had my friend's dad out going over everything. So, now it is all working fine, and it is my guess that it is a problem that can be addressed and added to my list of things my hubby can figure out when he gets home. Poor guy, he gets a larger than normal honey do list. I can go ahead and check out the flasher unit though, I guess it is worth looking into. Where is it located, and how do I go about checking it?

Tiny
Navywife
Jun 6, 2006.
Its inside the dash. You must remove the entire dashboard to get to it.

Tiny
Lsussel
Jun 6, 2006.
Oh, thanks for the help, but unless it decided to go crazy again, I don't think I will be going after that one. Are there any other issues that could lead to my problem?
AD

Tiny
Navywife
Jun 7, 2006.

AD