Mechanics

302 V8 - HIGH IDLE FIX

1993 Ford Thunderbird

**This is not a question, but a problem> diagnose> solution posting to aid others with similar issues**

Year: 1993
Make: Ford
Model: Thunderbird LX
Engine: 302 v8
140,000 miles

Problem: Engine started to idle high, normal is ~800, now is at 1900 steady. Runs and drives fine, but acts as if you have the throttle pressed, can go from 0 to 65 without touching the pedal. Issue is present either cool or warm engine. Check engine light is off.

Diagnose:
-Visual inspection of hoses to throttle body, check for leaks, cracks. Passes.
-Used carb cleaner spray on connectors to check for leaks while engine is on. No change in RPM.
-Verified throttle was not sticking.
-Gave a few taps with a screwdriver on the mass air flow sensor, adjusted wires to check for short/open. No change.
-Disconnected wire harness from mass air flow sensor at air box, started engine. Engine fires but immediately dies. (Normal) Reconnect.
-Disconnected Idle Air Control sensor wire harness on throttle body. Started engine. No change. IAC could be stuck. Gave a few taps, no change.
-Replaced IAC sensor (80 bucks, motorcraft). Engine idles and runs as it should.

Correct if wrong but I believe the IAC allows air to bypass the main throttle when gas is released to keep engine running. I think mine was stuck " open".

I have no access to special diagnosis equipment to read error codes. Hopefully this will assist people who have a similar problem.
Avatar
Wingman2k
June 10, 2007.



Check out the related content below while we wait for the question to be answered by a professional mechanic.