Mechanics

MAP OR MAF SENSOR PROBLEM, NO HORSE POWER,

2002 Ford Taurus

Engine Performance problem
2002 Ford Taurus 6 cyl Two Wheel Drive Automatic

My Ford Taurus 2002 has lost horse power and won't accelerate like it used to. My current max speed is 40 mph. Sometimes the car feels like it is going to shut down and it staggers randomly. People are telling me that the MAP sensor needs to be changed however the scanner is currently pointing to the MAF sensor P1101. I am also having problems locating the MAP sensor on the car. I have checked the internet and knows what it should look like.

Note I had to change my fuel pump couple months ago and notice that the car's performance was not the same after new pump was installed. It had poor acceleration and my max speed was 60 mph. I took the car to be scanned and it had error code P1401 and had to purchase an new EGR sensor. I thought this would fix the problem but it only got worst which has deteriorated to what it is now. I am afraid this problem is more than just the MAF or MAP sensors. I really need help with this one - Please help! I also fair that I have been ripped off by my mechanic with the fuel pump replacement - the car was not starting. He told me that the fuel was not reaching the engine.
Avatar
Phudsonbz
April 3, 2010.




If the computer is pointing toward the MAF, that is the direction I would go. Replacing the MAP is just a guess at this point. To be honest, a bad MAP will usually shut the car down and then it will restart, but not cause the power loss you have described.

What I recommed trying is to clean the MAF. They make a special cleaner for them that you can get at most parts store. Try that, have the computer reset, and see if it sets the same code again.

Let me know what you find and Happy Easter.

Joe



AD