Mechanics

EGR VALVE

1999 Ford Taurus

I have a 1999 Ford Taurus w/ 6cyl. Engine. Engine trouble code showed up as an EGR insufficient flow detected. I replaced EGR valve. Code stayed gone for a few days and reappeared as same problem. Ive looked for vacuum leaks but cant seem to find one. Car seems to idle high on start but goes down withing a minute or two. Any suggestions?
AD
Avatar
Kfuller
March 5, 2007.



Usually it's not the egr valve itself, it's the dpfe sensor, that little gray plastic thing with a couple of small rubber hoses attached to it, they are a known failure part. Their job is to detect flow. Egr valves I've never replaced one. What is the code you got? As far as high idle, it's programmed that way from a dead-cold start, unless you're experiencing a really high idle, then there may be another issue

Tiny
TaurusWheel
Mar 5, 2007.
Check the DPFE sensor as recommended my dime is on it.

Rasmataz
Mar 5, 2007.
Don't replace any more parts till you remove the erg and clean the channel inside. You will find it's caked with carbon. I use a steel coathanger to do it! Then have the light turned off at autozone. If it comes back on replace the egr position sensor. Let me know! Clean or push the coathanger till you can see it in the throttle body at the butterfly. Let me guess the code is p0401? You must have the computer reset for the light to go out! Or drive it 15 times on the highway for some distance.
AD

Merlin2021
Mar 5, 2007.
Yes, the code is po401. Ive had the code cleared twice. It stays off for a day or two and then comes back on, throwing the same code. I rechecked the carbon build up today in the new parts, clean. Havent checked the egr position sensor though or the dpfe sensor.

Tiny
Kfuller
Mar 6, 2007.

AD