Mechanics

CAM POSITIONING SENSOR LIGHT

1999 Ford Explorer

Engine Mechanical problem
1999 Ford Explorer V8 Two Wheel Drive Automatic 175000 miles

MY CHECK ENGINE LIGHT CAME ON, AND WHEN I HAD IT CHECKED I WAS TOLD IT WAS THE CAM POSITIONING SENSOR. I REPLACED THE SENSOR AND HAD THE SYSTEM RESET, WITHIN A MILE OF THE SHOP THE CHECK ENGINE LIGHT CAME BACK ON, I RETURNED TO THE SHOP AND HAD THE SYSTEM CHECKED AGAIN, ONLY TO BE TOLD I HAD A BAD CPS, I TOLD THEM I HAD REPLACED IT AND WAS TOLD THAT THE NEW ONE MUST BE DEFECTIVE AND THAT WAS THE PROBLEM. SO FOR THE SECOND TIME IN TWO DAYS I REPLACED THE CPS, HAD THE CHECK ENGINE LIGHT RESET, A DAY LATER THE LIGHT IS BACK ON. I CAN FEEL THE CAR MISFIRE OR BUCK AND IT SEEMS TO BE IDLEING FAST. SO HERE I AM ASKING YOU FOR YOUR HELP
THANK YOU FOR YOUR TIME AND EFFORTS
Avatar
Marc33778
July 28, 2010.




Hi, Was The Lower part of this sensor replaced?Does This Sensor Mount With Two little Screws? Or Does It Mount In The block.

Hope This Helps You,
Edward S.

Tiny
Edward.S
Jul 28, 2010.
This was the top part it was held on with two screws and on wire connection with two wires thank you for your time

Tiny
Marc33778
Jul 28, 2010.
Hi, Was The Lower Part Ever Replaced? And Was It Installed correctly. Ford Has A special tool To Align The Top Part Of The sensor with the lower. But I've Done Them without this Tool. If the Lower Part Was not replaced ever, I'd start there, But Since You Have a lot Of Miles On this Car, Even this Is a gamble. You Could Replace This part and, Still get this code. Cause Of the High mileage. You Can try If you Want, Or Leave It Alone.

Hope This Helps You,
Good Luck
Edward S.
AD

Tiny
Edward.S
Jul 29, 2010.

AD