Mechanics

FUEL CUTOFF LIGHT

Ford Escort

93 escort 1.9 150k

wife ran the car out of gas 2 years ago and I still can not fix the issue it has had since

she ran it almost completly out of gas but the fuelcut off kicked in light came on etc. Put gas in started it up fuel cut off light came one killed the car hit key agian ran fine went and filled it up

ok trick is now 99% time you start the car the cutoff light turns on and shuts off the car hit the key agian works great runs great

but as I have tried many things and no clue why the cutoff light keeps coming on or what controls the dang thing its driving me nuts lol
Is there a reset? Is there a sensor I need replaced that I have no idea about?
so far is only thing I havent been able to pinpiont

Nothing comes up on codes
I have replaced pump a few times replaced the filter the regulator the tank (had leak issues wasnt all to fix this problem)

either way if anyone can help it woudl be great
Avatar
Death69
May 25, 2007.



I would check the fuel pump relay. It may have a weak coil.

Tiny
Rudpro
May 25, 2007.
Replaced the relay no change

Tiny
Death69
Jun 4, 2007.
I tried doing some research on this and I am stumped too. The only thing I can find is that on the wiring diagram, the inertia switch that cuts off the fuel pump is tied into the passive restraint system. Maybe someone else could help with this, I'm not familiar with it.

Tiny
Rudpro
Jun 4, 2007.
Sounds like the inertia swithc^^ thing is I dont think running it out of fuel will cause this

Blackop555
Jun 4, 2007.
I found some people with similar problems on other forums and couldn't find any answers. One guy said he was going to clean his inertia switch, it had a lot of oxidation on it but he never posted back if that fixed it. Another said if he turned the key on for 30 seconds before starting it would start. Another said he was taking his Escort to a dealer to see if the light could be reset. No one posted back if they had fixed the problem though. I could see where if the switch was heavily oxidized it might be malfuctioning. I think he should check his owners manual, if he has one, for any info that might be in there.

Tiny
Rudpro
Jun 4, 2007.