Mechanics

WAGON 1.9 LITER ROUGH IDLE AND DIED

1994 Ford Escort

1994 escort 215000 miles, fuel injected 1.9 liter with auto transmission. Hello. Within the last year I have had an intermittent problem and now its gotten worse.I would driver my car on lunch hour and go approx 5 miles and shut the car off. When I would restart it about 20 minutes later it would idle rough but come out of it when I would start driving back to work. It would idle fine at stop lights and such and maybe wouldnt occur again for a couple weeks. Last night I drove my car for approx half an hour and stopped on the way home. It ran fine and I shut the car off.I tryed to resart it about 20 minutes to half hour later and it ran really rough and died.I tryed several times to restart it and it would fire once or twice but not for very long.I shot a spray of starting fluid into it and it ran fine until it the starting fluid was used up. It did that 4 or 5 times. Then it started running fine by itself.I drove the car home another half an hour and it ran just fine, (not a miss or lack of power). When I got home I shut the car off and restarted it right back up.I shut it off again and and tryed to restart it and this time just a hint of firing once or twice.I noticed that when it wouldnt start if I pushed on the accelerator then it wouldnt fire at all and seemed less likely to start after I did that.I was thinking about the oxygen sensor or spark plugs and wires but beyond that I have no idea. Any help would be appreciated
AD
Avatar
Horse
May 10, 2007.




Check out the related content below while we wait for the question to be answered by a professional mechanic.


AD