Mechanics

CAR LACKS ACCELERATION BUT IS GETTING PLENTY OF FUEL.

Dodge Eagle Vision

I asked this question about my Eagle Vision but will ask here Since Dodge Intrepid is almost exactly the same. Maybe someone has had the same problem.

1993 Eagle Vision TSI 3.5 liter 24 Valve 132000mi

Car starts and idles fine. Accelerates fine for about 40 feet then drops. Does not die; does not over rev; gets hot slightly faster than normal. Tranny is not slipping. Fluid levels are all fine. Rpm range just barely above normal. Stop and try to go again and it barely wants to move. Turn the car off then back on and it will drive fine for about 40 feet again then it happens again. Does not want to go past around 30 mph. This is on flat land. It normally is a very fast accelerating car. This happened very sudden. No warnings. Feels almost as if it's stuck in a higher gear but if so would have no problems going faster.
I recently replaced the fuel filter and had the tranny resealed. Oil has been changed in last 2000 miles. Car seems to run a little rich but has been that way since I bought it about 4 months ago. Revs fine. Feels like I'm pulling a Tractor up a hill while on flat land. Scared to drive it to further test or try to get more info to help with diagnosis.

Please help me!
I am lost without my car and have been renting to get to work and back. It's costing me a boatlod of cash I don't have.
Avatar
Sassie2u2me
January 30, 2007.




Have you checked the fuel pump pressure? Also, have you checked to make sure the catalytic converter isn't plugged?



AD