Mechanics

CHUGGING WITH ENGINE LIGHT ON

1997 Dodge Avenger

Engine Performance problem
1997 Dodge Avenger 6 cyl Front Wheel Drive Automatic 134, 00 miles

i have a 97 dodge avenger that started chugging and engine light was on. Dealership diagnosis was number 4 cylinder had a misfire due to worn out boots on valave cover gasket. I changed out gasket and boots on plug well and put in new plugs and plug wires and now its chugging again. Computer diagnosis from autozone is picking up an injector malfunction on number four cylinder. How do I fix it?
Avatar
Andrew2120
June 11, 2010.



Could you please get me that code number's your car has so I can help you with this.

Saturntech9
Jun 11, 2010.
I am not sure of what code number you r talking about. I didnt take the car to autozone but my girlfriend did. She just brought me the printout from the computer reading

Tiny
Andrew2120
Jun 11, 2010.
Well on the print out there should be some code number's they will start with the P and have four digit's after that. So tell me what they all are.

Saturntech9
Jun 11, 2010.
Ok well the code that the computer was picking up was po204.

Tiny
Andrew2120
Jun 12, 2010.
I emailed you the information for you code p0204 to your personal email. Let me know what you find.

Saturntech9
Jun 12, 2010.
Ok thanks i'll check my email for the info. And one more question. Do you happen to know the torque specifications for the air intake bolts?

Tiny
Andrew2120
Jun 12, 2010.
Do you mean for your air filter box or your intake manifold?

Saturntech9
Jun 12, 2010.