Mechanics

NO SPEEDOMETER,FULL GAUAGE, NO

2000 Chrysler Grand Voyager

2000 Chrysler Grand Voyager 6 cyl

all my gauges on the cluster (speedometer, tach, fuel gauage, temp gauage, odemeter, and shift information) is gone. My abs light, service engine soon and air bag light are lite too. When it put on the computer it states that everything is good right. Can you help with this?
Avatar
Jasonj70
October 24, 2009.



Where is this fuses box located there are 2 of them. I could not see the diagram well enough too small.
Is there somewhere we can see a bigger diagram?

Tiny
Jasonj70
Oct 28, 2009.


http://www.2carpros.com/forum/automotive_pictures/198357_Graphic_222.jpg


Docfixit
Oct 28, 2009.
All the fuses in the fuse box are good. Tested them with a test lite. Could it be a relay?

Tiny
Jasonj70
Oct 28, 2009.
Having trouble locating another fuse box. There is one under instrument panel?
Seems a change was made in model year what is production date?

Docfixit
Oct 28, 2009.
The production date is 4/99

Tiny
Jasonj70
Oct 28, 2009.
I have had the fly wheel replaced also.

Tiny
Jasonj70
Oct 29, 2009.
In junction panel under left side dash check fuse #2 a 10 amp. Is PRNDL light out?

Docfixit
Oct 29, 2009.
Yes the lite is out and the odemeter is too.

Tiny
Jasonj70
Oct 30, 2009.
ALL THE FUSES ARE GOOD IN BOTH FUSE BOXES; UNDER THE DASH AND UNDER THE HOOD ON THE LEFT HAND SIDE.

Tiny
Jasonj70
Oct 30, 2009.
No gauages work, the heater is stuck in defrost mode, no buttons work, on the heater panel.

Tiny
Jasonj70
Nov 2, 2009.
Page 2 of 2