Mechanics

CAR DIED WHILE DRIVING, LOST ACCELERATION, WHAT IS WRONG?

Chrysler Concorde

Hi,
Thanks to whoever may respond. I was driving my 95 chrysler concord, with 95K miles, and a v6 engine today. The car made no noise, and the engine is extremely quiet. Suddenly, I started to lose acceleration, the gas pedal was stiff, and the steering wheel became stiff. While all of this was happening, the oil light and cruise control light came on ( I was not using cruise control ). I immediately pulled over. There was no noise, shaking, or smells. I checked the oil and it was very low. Car will not start again. Had to tow it. I did not add oil to the car but there was oil all over the tow bed when my car came off of it. Is my engine fried? I added oil after the tow, and it won't start. When I turn the key, it tries to start but won't turn over. It sounds like it will catch and does nothing. Please let me know if you have any idea of what is wrong. Thank You
Avatar
Enchanted
November 29, 2007.



U need to check if you have spark and if the fuel pump pumping fuel in to the system
Pull one of the spark plug wire and check if it spark while cranking the engine if not you may need crank sensor
Let me know also if you hear the fuel pump coming on or not
Good luck

BMRFIXIT
Nov 30, 2007.
Hi,

BMRFIXIT,

Thank you for your response. I just had it towed to the repair shop. I thought maybe it had something to do with the fuel pump. I just hope the car isn't totally gone and the repairs don't cost more than the worth of the car, which isn't much.

I guess I will find out tomorrow.

I appreciate it.

Tiny
Enchanted
Nov 30, 2007.
Good luck
let me know what happen

BMRFIXIT
Nov 30, 2007.