Mechanics

CHEVY CHEVY C1500 PU BATTERY KEEPS LOOSING

1996 Chevrolet Truck

Electrical problem
1996 Chevy Truck V8 Two Wheel Drive Automatic

96 Chevy C1500 PU battery keeps dying on me. I replaced the alternator/battery. No lose con. Nothing worked?
Th The truck ran fine the day it died. I took it out 4 times and the fifth time the battery was dead. The volt gauge inside reads at 10 volts and drops as the battery dies. I am not sure if the gauge worked before though? I jumped it and it started right up. Then it would not stay running because it didn't have 12 volts. Since the battery charged up with my house AC battery charger I assumed the battery was good. I replaced the alternator, this didn't fix the problem. It still would loose its charge and then die. So, I put the old alternator back in. I figured I'll try the battery just in the slightest chance that was the problem, but it didn't make any sense. The battery just lost charge and the truck died again after a half hour( the lights, radio, and heater on.) So I know it's not the battery or the alternator? Everything appears to be tight with no loose connections? I have no idea where to go from here? Please help I am on a tight budget since my wife and I have both have been laid off in the past 3 months. I can do the work myself as I always do but I can't trouble shoot this? Thanks in Advance
Avatar
Tac1971
January 18, 2009.



Check out the related content below while we wait for the question to be answered by a professional mechanic.