Mechanics

CHEVY BUZZING BEHIND INSTURMENT CLUSTER

1993 Chevrolet S-10

Noises problem
1993 Chevy S-10 6 cyl Two Wheel Drive Manual

when approaching 65 mph, a buzzing sound starts behind the steering wheel, insturment cluster, it sounds like a a bad/worn speedometer cable, however, I dont believe that this model has a mechanical cable. The sound only starts at around 65 and up, speedometer still works. Thanks for any help
Avatar
Wesleydawson
September 10, 2010.



In 1993 these do have a speedocable. The cable may have been pulled on if any underdash repairs have been done recently, hense your noise. The cable may be frayed, and that could be causing your noise also. It can be a pretty agravation job if your tackling it in the driveway. What are your capabilities? May be easier bringing it to a garage.

Madmike1735
Sep 10, 2010.
I have pulled instrument cluster and and have looked for a cable. However I didn't see one. Large electrical connecter in dash which connects to back of instrument cluster. Have looked on transmission and didn't see a cable running up from it. Just some wiring. Any suggestions on routing of cable. That is what I thought it was but online research said that chevy changed over to electrical speed sensors with introduction of fuel injection. Thanks for your very quick reply earlier!

Tiny
Wesleydawson
Sep 10, 2010.
You would see the cable if it had one. Im surprised it doesnt. I know that some 93s have them, you maybe you have a later production date. As far as the noise goes, im stumped.

Madmike1735
Sep 11, 2010.