Mechanics

CHEVY ENGINE MISS ON IDLE

2001 Chevrolet Impala

Engine Performance problem
2001 Chevy Impala 6 cyl Front Wheel Drive Automatic 114000 miles

I have an ongoing mild engine miss when idling. I have already replace the fuel filter, spark plugs, wires and added a gas additive. I have also checked for arcing at night on the wires, but haven't been able to find any problems there. The car worked fine until I recently had the transmission overhauled. Could there be something that they may have done to create this problem. The service engine light has not come on or any other codes. Is there something else that may be causing this miss in the engine. Please let me know what you think.
Thanks
Brian
Avatar
SHULL1959
October 25, 2008.



Hi Brian: Since there are no codes, and the problem started after the trans repairs, I would look for a vacuum problem. They may have left a hose off or damaged one without realizing.

Let me knowif this helps, or if you have any other questions.

Joe

Thanks Joe for replying.

I have had a look to see if any vacuum lines were off or pinched shortly after this started and didn't really see anything. I will go overthem again, I might have missed something and let you know.

Thanks
Brian

Tiny
SHULL1959
Oct 26, 2008.
Hi Joe; I just went over the car again and couldn't see any lines that were lose, kinked or off. Look like we are back to square one. Someone else mentioned putting Berryman's B-12 cleaner in it for the injectors. Their thought is possibly fuel. I have already put in injector cleaner and changed the fuel filter. Do you think that this would help or a waste of money?

Tiny
SHULL1959
Oct 26, 2008.