Mechanics

CHEVY ACCELERATION, SHIFTS HARD, BRAKE CLICKS,

2001 Chevrolet Impala

2001 Chevy Impala 4 cyl Automatic 99,000 miles

I am having multiple problems with my car at this moment. I thought my transmission was going out because one day I push on the gas and it feels like it's in neutral and then it shifted hard. It reversed normal though. I have taken it to a transmission place 3 different times but they didn't find anything wrong.
At the same time that happened my brake was clicking when I let off the brake. Never did it before until then.
Now, my cruise control stops working and then works again a different time. My automatic locks that unlock when I put car in park stops working occasionally. My engine light has come on (code was checked and nothing abnormal besides temperature sensor which was replaced.)
I can't explain quite right what it's doing when driving. Even when I had it in cruise control it felt like it was skipping, or gas stopped flowing to it, like I am letting off and on the accelerator. I turned off the air conditioner to see if that would make a difference, it seemed to make a difference as far as when I pushed on accelerator it actually was going normally it still shifted hard here and there but it actually had normal speed when putting pressure on accelerator. I put my car into 3rd gear for less then a minute and it didn't shift hard.
Is this something electrical?
Thanks for your time.
Avatar
Blckcatkris
July 9, 2010.



Hi blckcatkris, Welcome to 2carpros and TY for the doantion.

Lets get the TPS and VSS checked and tested this 2 deals with the tranny's throttle and governor pressures- if okay could be a shifting solenoid hanging up, also you can try disconnecting the TCC splenoid and see what happens

Rasmataz
Jul 12, 2010.