Mechanics

CHEVY ODOMETER LIGHT

2001 Chevrolet Impala

2001 Chevy Impala 6 cyl Two Wheel Drive Automatic 105000 miles

The odometer light on my 2001 Impala has suddenly stopped working. The problem began with the light being dim (too dim to really see). But this was only intermittent. It would go from dim to bright being either one or the other with each start. But now, the light is staying off permanently. All the other dash lights work. Also, sometimes my turn signals won't work. I have to push the hazard button several times and then the blinkers will work. Sometimes they shut off automatically after being turned on and working getting ready for a turn. My third problem is my check engine light referring to the emissions control system is on. Owners manual suggests checking the gas cap, which I did. After 2-3 starts the light is still on. My gas gauge does not work either but after reading the forum, this could be the fuel level sensor. Can you tell me where that is located, or is this a mechanic fix. Thanks for helping out the " dumb woman".
Avatar
Jhunter915
December 6, 2008.



First of all, my wife says there is no such thing as a " dumb woman", they're just " misunderstood". Now that we've gotten that out of the way, on to your problem. On your odometer light, I would first change the bulb, it could be just a poor connection.
The fuel gauge sending unit is in the fuel tank. There are tests that can be done before you condem the unit, but these would have to be done by someone who understands the wiring system. You may have to have a mechanic look at it.
Check engine light: Tou should have the ECM memory " scanned" to find out what trouble codes are stored in memory. Autozone will this for free as well as most major parts stores. Once you have this code(s), we can help you pinpoint the problem.
Turn signals: This sounds like it could just be the flasher.
Please advise.

Tiny
James W.
Dec 7, 2008.
James: Thank you so much for your answer. I love your wife, already and she seems to be a " smart woman". I will have the ECM scanned at Auto Zone today. Last night while going to the store, I checked my numbers on the DIC system since this is the only way I have to keep track of fuel consumption. It shows that I am only getting 14 MPG. I was getting 28 to 30 MPG so this is a big concern. I will let you know as soon as I get the codes. Again, thank you so much.

Tiny
Jhunter915
Dec 7, 2008.
Hi. I went to Auto Zone and had the memory scanned. It came up as " Cylinder 1 misfire". The guys at Auto Zone said it was either the spark plugs or the spark plug wires. Here's the deal. I had a tune up on this car with plugs replaced in July 2008. I can't remember if the mechanic replaced the wires. Is this indeed the problem or is it something else? Also, that odometer light comes on and off when I wiggle the trip odometer knob. It will not stay on for any length of time. Does this indicate a short? Please let me know as soon as you get a chance and thank you very much for your help and advice.

Tiny
Jhunter915
Dec 7, 2008.