Mechanics

HELP, FAN WON'T COME ON. 86

1986 Chevrolet Celebrity

I have an 86 Chevy celebrity 2.8 v-6 VIN W.
I just replaced cracked heads. Engine starts and runs fine. No engine light. No codes. Thermostat ok. Electric fan won't start at all. Temp light comes on. Fuse ok. No working fan with a/c on.

Installed 3 different relays & fan switches, no fan. Back probed and grounded red terminal on relay and got a light. Grounded green terminal on relay and fan turns on. Manual says to check fusible link C next to starter. Located them but they aren't labeled A, C or F. Does anyone know how to id fusible link C, diagnose it & replaced it. Something else I should check?

Thanks for your help.
Avatar
Gmlover
January 24, 2007.




Hey GM,
Your relay test just ruled out the fusible links ....the fan came on when grounding green terminal ...There is a cooling fan temp switch located on the backside of the motor .....looks like its close to the coolant temp sensor ......maybe this has failed or wasn't hooked up? Let me know!

Chris


http://www.2carpros.com/forum/automotive_pictures/47722_celeb_1.jpg


Tiny
Carundell
Jan 24, 2007.
Hey GM,
Your relay test just ruled out the fusible links ....the fan came on when grounding green terminal ...There is a cooling fan temp switch located on the backside of the motor .....looks like its close to the coolant temp sensor ......maybe this has failed or wasn't hooked up? Let me know!

Chris


http://www.2carpros.com/forum/automotive_pictures/47722_celeb_1.jpg

[/quote:4ca6598f6c]

Cris,

Thank you for your response and the image. I did replace the switch and relay with used parts. I installed 3 different relays and 3 switches. Can you tell me how to test thouse parts? If they test ok, how can I test & verify the computer is sending signal?

Thanks
AD

Tiny
Gmlover
Jan 25, 2007.

AD