Mechanics

CHEVY AC NOT KICKING ON

2000 Chevrolet Cavalier

Air Conditioning problem
2000 Chevy Cavalier 4 cyl Front Wheel Drive Automatic 100000 miles

About a week and a half ago I took my car in to have the water pump replaced and the serpentine belt replaced since I did not have the time to do it at home.

Well when I get the car back the mechanic asked me if I had any problems with the gauges cause when he pulled the car out they werent working do he pulled the ruse and put it back in and they worked again. Well later that day I went to turn the air on and I did not feel the pull on the engine. I checked to make sure the belt is on correct which it was and I have reseated the fuses w/o any luck. Could it possibly be a fuse or could it be a problem with the installation of the belt.
when I depress the ac button in the car the light comes on but as I stated I dont get the pull on the engine and no cold air comes out. Is my pump bad? Or is it a fuse?

edit: I have also disconnected the battery for ten min and reconnected it w/o any different results
Avatar
Agleisberg
April 27, 2008.




Could be low on freon, bad relay, pressure switch and compressor itself.

Rasmataz
Apr 27, 2008.
Would low freon cause it not to pull at all? I figured if it was low it would still atleast atempt to work. And it was working 24 hours prior to the car being taken in. Should I try a fuse?

Tiny
Agleisberg
Apr 27, 2008.
Get the AC pressures check this will tell if it needs freon

Check the blower fuse 30amp, AC fuse 10amp, ERLS 10amp.

Is the blower motor working?

Rasmataz
Apr 27, 2008.
Yeah. The 2nd setting doesnt work but hasnt for a year otherwise yes its working. I have checked the fuses going to try to replace them later in the week to see if that helps.
AD

Tiny
Agleisberg
Apr 27, 2008.

AD