Mechanics

CHEVY CAR RUNS BAD WHEN COLD AND OPER TEMP

1994 Chevrolet Camaro

Engine Performance problem
1994 Chevy Camaro V8 Two Wheel Drive Automatic 98000 miles

when I go out in the mornings to start my car it starts right up no problems but when I go to take off and it is still cold it like missfires and when my engine gets to or gets close to operating temp my idle slows down about 300 rpm's and it spits and sputters when I hit the gas no matter the rpm's and I feel I HUGE! Power reduction and alot of black smoke comes out.I just put new ac delco platinum plugs.8mm summit plug wires.48,000 volt msd street fire coil. New accel peformance cap and rotor kit. And a flowmaster 80 series cat back exhaust system. Please let me know what this could be I put all this money in this beautiful car and it runs like crap
AD
Avatar
Fbalstud
August 16, 2009.




Dirty fuel injectors (cleaning the injectors often fixes this).
Bad MAP (manifold absolute pressure) sensor
Bad TPS (throttle position) sensor
Bad or dirty MAF (mass airflow) sensor
Low fuel pressure (leaky fuel pressure regulator or weak fuel pump)
Vacuum leaks (intake manifold, vacuum hoses, throttle body, EGR valve)
Bad gasoline (fuel contaminated with water or too much alcohol)

Sometimes, what feels like a hesitation is actually ignition misfire rather than lean misfire. The causes of ignition misfire may include: Dirty or worn spark plugs
Bad plug wires
Weak ignition coil
Wet plug wires

Rasmataz
Aug 16, 2009.
It starting doing it only at operating temp now it is doing it as soon as I start it up and I have always put injector cleaner in it and kept up on the repairs it smells really badly like gas when I shut it off
AD

Tiny
Fbalstud
Aug 17, 2009.
Check the fuel pressure and comeback with the readings. Did you check the stuffs I've suggested earlier?

Rasmataz
Aug 17, 2009.

AD