Mechanics

CAR KEEPS DYING

1999 Saturn SL2 • 140,000 miles

My car just keeps dying while I am driving. I'll be driving and it's like the engine just shuts down. The lights and radio still come on, but it won't start. If I let it sit for a few hours it will start but it will only drive for about a minute before it dies again. When I try to start it after it dies, it starts shaking badly. The water pump was leaking and I had it changed, but the car dying started after I found out about the leaky water pump.
Avatar
Kyanna012
April 21, 2013.



Do you have any codes? Also when it dies it will start but starts and runs and shakes a lot?Have you checked your coolant temp sensor and connector?

Saturntech9
Apr 21, 2013.
The only light that is on is the service engine light, but that has been on since I had the car. When it dies it won't start again. It just shakes like it's trying to start. I think the coolant is okay but I am not sure how to change the connector

Tiny
Kyanna012
Apr 21, 2013.
The first thing you need to do is have the car scanned for codes and let me know the exact code numbers not code descriptions? Just because the light has been on doesn't mean there isn't codes that can't help us now. To check the coolant temp sensor connector unplug it look inside the connector if the terminals are blue or green instead of silver the connector is bad.I would just replace the sensor there only 11 and fail a lot. Have you checked for spark when it won't start?

Saturntech9
Apr 21, 2013.