Mechanics

MY CAR SEEMS TO STUDDER WHILE GENTLY ACCELERATING?

2009 Saturn Aura • 65,000 miles

It revs up just fine, I checked the fuel pressure and it's running at 60psi and when the engine is reved up it stays at 60psi. I pulled the injectors and they seem to be working fine. But while I'm driving 45-75 mph I can feel the car studder. The tach also flutters a bit when I can feel it. It only use to do this when I would push on the gas and put some load on the engine ( first noticed it when going up hill slightly )now it does intermittently while driving on flat roads also. I don't know what else to check. It's not putting any check engine lights or codes on. 2009 Saturn aura 2.4lL
Avatar
Tmckenzie
July 20, 2012.




Is it worse with the ac on?Also have you checked for codes I kniw you said you dont have any but did you check for any?


Saturntech9
Jul 20, 2012.
I checked it for codes today, it didn't have any. I haven't checked with ac off. I will


Tiny
Tmckenzie
Jul 21, 2012.
If its worse with ac off its most likey a ignition issue spark plugs failing coil etc.


Saturntech9
Jul 21, 2012.
I just drove it and it seems to bit worse with the ac off, it shutters more frequent. I also forgot to mention when I pulled the injectors one of them came out pretty tuff and the nozzle looked a bit burnt, the others looked nice and clean. How can I test the coil packs? And would one be going bad without throwing a check engine with a code?


Tiny
Tmckenzie
Jul 21, 2012.
Iam sorry I ment to say if it was worse with the ac on?So is it worse with the ac on?Also if one of the injectors tips looked burnt that would be a dirty injector since there is really nothing at the tip of the injector to be burnt.I have bad coils set codes and have also seen them not set codes.


Saturntech9
Jul 21, 2012.
Is there a way I can test the coil packs?


Tiny
Tmckenzie
Jul 21, 2012.
I drove it again and yes your right its more pronounced with the ac on. I can feel it when it's off, but turned back on its much more noticeable.


Tiny
Tmckenzie
Jul 21, 2012.
I posted a trouble tree for the ignition system dont replace anything just follow the trouble all the way down. That way you can test the wires etc. Heres the problem with a problem like your having it is a coil issue which we dont know that it is. Its only failing under load I also dont put much faith in testing the coil with a ohms meter. My sisters honda had no spark only had one coil it tested good ohms wise. Found a plused trigger to the coil so I new the coil was bad. It sounds like a coil issue since with the air on it cuts out worse. Most of the ones I have seen like that turned out to be a ignition issue.I would also check the spark plugs visually look at them for cracks black carbon etc.
AD


Saturntech9
Jul 23, 2012.

AD