Mechanics

MAZDA CX7 BATTERY PROBLEM

2009 Mazda CX7 • 70,000 miles

I am having trouble when starting my CX7. It starts, but it is sluggish sometimes. I took it to the dealer service department and they had it about 48 hours and couldn't get it to do it. Ran diagnostics and said it wasn't the starter, battery, or alternator. Couldn't find anything and have the car back. It then started fine a couple times and now is sluggish again. The problem seems to happen after I have driven and then it sits a few hours. I'm at a loss and don't want to have to wait for it to leave me stranded somewhere before I find out what's going on. Thanks!
Avatar
RMK1981
February 23, 2013.



So is it a slow crank speed and hard to start? Bit like a battery going flat?

Mhpautos
Feb 23, 2013.
It's not the battery. It was replaced in November and then again last week because that's what the mechanic first thought.

Tiny
RMK1981
Feb 23, 2013.
But yes, to answer your question. It acts like a battery going flat. But then the battery tests fine.

Tiny
RMK1981
Feb 23, 2013.
Slow cranking can be polling starter motor, poor earth, low starter cranking voltage, high resistance across the solenoid contacts, have these been checked as yet?

Mhpautos
Feb 24, 2013.
To my knowledge none of that was checked. I will call Monday and ask them to tell me everything that they checked. Thank you.

Tiny
RMK1981
Feb 24, 2013.
I called the service department and they did the following: checked battery; checked alternator; checked starter; tested charging system; checked for error codes; and made sure the terminals were tight.

I've also noticed that it only has a slow start after I've driven for about an hour. It's fine around town.

Tiny
RMK1981
Feb 26, 2013.