Mechanics

4 X 4 GRINDING

2007 Jeep Wrangler • 6 cylinder 4WD Automatic • 80,000 miles

Bad grinding noise from the front half of my 2007 jk rubicon when 4 wheel drive is engaged. No noise at all at any speed in 2 wheel drive.
Avatar
Mrijeff
February 9, 2011.




I know little of your "Newer" Jeep

Imma CJ Guy, a member like you, and I answer the CJ 5 and 7 forums a lot.

Have you crawled under and looked for something rubbing----Something like WIRE, maybe wrapped up somewhere on your drive shaft.

When I was still in the Army, The bolts securing my Transmission/ transfer case to the Skid plate fell out. When in 4X4, my "Stuff" (rear of engine and all!) Would slide toward the passenger side and the FRT drive-shaft yokes would rub the frame, while the shaft was rotating.

It was something you would never expect, and it usually had slid back, when I started looking for the noise.

Depending on how far you want to take this search, here's other things you might look for: One of your locking hubs, NOT locking in Fully.I can explain how to test on a CJ. Not sure about your system.

Slop in your front pinion bearings

Drop your Rear Driveshaft completely and see if FRT Wheel Drive works (4 high or low, with no rear shaft on). Locking hub not engaged, broken axle etc

Has your Jeep been subjected to recent H. Ell Damage!

I will continue to try to aid you. You know my situation.

Others can hop on here too, So the more info, in detail you give, the better "We" might assist you.

I saw your question had been waiting, and I know what it's like to be without your Best-us Pal! (Mr. Jeep). So I threw you a bone, Not a Real Meaty Bone, but never the less, something!

Your Turn. Keep us informed, "someone" will try to assist, if need be!

The Medic

CJ MEDEVAC
Feb 11, 2011.


AD