Mechanics

SCION XA ENGINE PROBLEM

2006 Scion xA • 120,000 miles

I have a 2006 scion xa with approx 120000 miles. I have literally had no problems with this car and I must say have ran it pretty hard. When I was driving home one night it felt like something was dragging down the back end and I immediatley thought I had my brake up and grabbed it and it wasnt up. It was running rough and missing and hesitating and couldnt get any power. Thats when I noticed my check engine light was on. I pulled off at an exit and while I was idling I thought it was going to stop. I stepped on the gas and it just slummped into the gas station. I had to back it up into a place and it sounded like it was making a scruffy sound in the rear end and dragging or sounded like something was dragging and also felt like the brake was up again. By this time the check engine like was flashing instead of stationary. My father replaced all the spark plugs (as I never ever did). I had someone plug one of those hand held computers to check it and he said it was a coil so my father replaced that. We test drove it and it was fine. My father drove it quite a ways down the road and he felt it missed a tiny bit at first but then it stopped. The engine light never came on. That is after a few hours after fixing it my daughter took it up the road and when she started it up again to come home the engine light was on again. She drove it home and its doing exactly the same thing it did when it first happend to me. Its like the coil was never replaced. And the rear end strangley is doing that pulling down feeling like the brake is up and making a scruffing sound or dragging, rolling type of sound when I backed it up again. What in the heck is causing this? I am not a rich person as a matter of fact im desperatly poor. I cant even afford the gas to go to work so having a major car repair is out of the question. Please tell me this is something that is not serious. If this little hand held computer pointed to this as the problem, was replaced, seemed to work but went back to not working. Why would it not have fixed it? Please give me a direction asap.
Thanks
Karen Sens
karensens@yahoo. Com
Avatar
Karensens
November 8, 2012.




Check out the related content below while we wait for the question to be answered by a professional mechanic.


AD