Mechanics

GEAR WONT ENGAGE CAR IDLE WELL OIL PRESSURE IS NORMAL

2006 Chrysler 300 • 3,800 miles

2006 srt8 7.0 engine.

It happend when I was racing on this day I heared a knocking sound at idle comming from front of the car it goes away when I drive. It happend at wot high rpm car suddenly idles high & gear wont engage with a sound of broking things down in the engine. Stoped the car switch it off & back on it idles well but when switching to drive rpm goes up little around 200-300 then goes back to normal but car wont move even in reverse what could it be? Im suspecting a broken flexplat?
Avatar
426man
August 11, 2012.



Sounds like your transmission is slipping bad-Do you have a check engine light? How's the transmission fluid and condition if okay bring it in and have it pressure tested to find out more what's going on.

Rasmataz
Aug 11, 2012.
Any codes in the computer?The flex plate would be easy to check I would check for codes first though.

Saturntech9
Aug 11, 2012.
No codes at all. Gonna check gear oil tomorrow cause my model does not have a dip stick. One more thing Iis that I dont feel anything when switching gears except rpm movement. I never had any trans problems before except the torque converter which I changed 3 months a go cause it was broken cause my car has a 500+ rwtq.

Tiny
426man
Aug 11, 2012.
Sounds like you have too much engine for the transmission and racing it doesnt help ethier. Is the transmission stock?

Saturntech9
Aug 11, 2012.
All stock I was planning to modify it later. I hope there is nothing with the engine

Tiny
426man
Aug 11, 2012.
When you really beef up the engine you always end up breaking the weakest link you need to beef up the whole drive train etc. Otherwise who knows what breaks next its design for the stock set up.

Saturntech9
Aug 11, 2012.
Could it be a crankshaft problem?

Tiny
426man
Aug 12, 2012.
It could be a lot different problems I doubt you broke the crank though.

Saturntech9
Aug 12, 2012.