Mechanics

BATTERY LIGHT ON

2005 Suzuki Aerio • 135,000 miles

Hello,
The Battery light came on, first, it would go out within a few minutes of driving but now it's on all the time.
Hence, now the alternator is not charging the Battery.

Here's what I've done so far;
I replaced the Battery, it was 4 yo (original only lasted 3yrs).
Took off alternator, and had is tested at AutoZone.
(serious pain to get off!)

Alternator passed all tests,
Lamp/Diode Trio Test - PASSED
Regulator Test - PASSED
Rectifier Test - PASSED

Put the alternator back on the car and battery light still comes on and the alternator is still not the battery.

So, now its on to the cable, harness, etc.
All main battery connections are clean and tight, all fuses checked good.

Checked for live wire on Alternator (car off), I got one live wire.

Checked for live wire in harness next to firewall on right side
(next to power steering resv)
Car is on, white/green wire is live,
Car is off, white/green wire is dead.
Solid green is always dead regardless of car on/off
Avatar
Poncepr64
July 4, 2012.




So off the car the alternato is charging on the test machine bu doesnt charge when installed back on the car?You checked the battery voltage at idle while it was running?If so what was the voltage?
AD

Saturntech9
Jul 4, 2012.
Hello,
12.95 car off
12.58 car on

Tiny
Poncepr64
Jul 4, 2012.
Also, that is with everything off on the car (radio, lights, etc)
If I turn any of those on, volts start dropping.

Tiny
Poncepr64
Jul 4, 2012.
Alright heres what I have for your alternator wires the black wire going to the alternator should have battery voltage all the time. The black wire with a white stripe should have power to the alternator with the key in the run position. Let me know what you find.

Saturntech9
Jul 4, 2012.
Black/wht stripe has power with key forward.

The other wire looks all white- no power an any time.
Main wire from battery has power.

Tiny
Poncepr64
Jul 4, 2012.
You should have power to the all black wire going to alternator. It should be a large gauge wire.

Saturntech9
Jul 4, 2012.
Yes. The main wire is all black and large gauge. Always has power. Sorry about delay in reply.
Just had a lightning/thunderstorm here in riverview, fl.

Tiny
Poncepr64
Jul 4, 2012.
I only see three wires in the wire diagram for your alternator the two that I said should have power and the blue one that supplys a ground to the battery light to turn it on. So both the wires I mentioned have full battery voltage at the alternator?Also there connections are clean and tight?Lets also make sure the case of the alternator is getting a good ground. Put your multimeter on low ohms scale like 200 ohm scale then take the black lead of the meter and hook it it to the negative battery cable. Then take the red lead and touch it to the case of the alternator. It should read 2 ohms or less?

Saturntech9
Jul 4, 2012.
Will check tomorrow afternoon, to many projects going on today.
Thanks for all the help. Thunderstorms we had here threw off my time.

Tiny
Poncepr64
Jul 5, 2012.
Alright keep me posted I know florida weather can be pretty crazy.

Saturntech9
Jul 5, 2012.

AD