Mechanics

K MILEAGE 61K MILES SUDDENLY EXTREMELY SHAKING AND CHECK ENGINE IS ON AND POWER LOSS , THEN I CHECKED THE CAR GOT CYL 2 MISSFIRE . WHAT IS THE PROBLEM ?THE CAR IS NORMAL BUT MISSING A LOT OF POWER ???

2005 Mercedes Benz C200 • 60,000 miles

C200 k mileage 61k miles suddenly extremely shaking and check engine is on and power loss, then I checked the car got cyl 2 missfire. What is the problem?The car is normal but missing a lot of power?


Avatar
Kais
January 14, 2012.



Check for faulty plugs and leads and check distributor cap for cracks or if coil pack ignition have coil tested.

Mhpautos
Jan 14, 2012.
What is distributor cap?And where is it in engine? I am afraid when I buy plugs and coils the problem will stay? I am afraid of loosing money without pos result? Is this problem common for c200 k? Have someone faced this problem and asked you before?Was this test the answer? Thank you in advanced

Tiny
Kais
Jan 14, 2012.
I have read your replies for the same problem and you suggested the problem of missing power maybe due to bad ground and you posted the ground chart. Is that possible for my issue? Thank you again

Tiny
Kais
Jan 14, 2012.
I did a quick test, I put the transmission on n and I floored the padel I noticed the revolution does not go up more than 4000 rev even I push the padel to floor? What the sign of this what can you imply from this test? The red max rev is at 6500 rev/min

Tiny
Kais
Jan 14, 2012.
Could be fuel related, or as I said earlier a coil fault, distributor cap, leads plugs or a sensor, so I would start with a diagionstic scan as this may give a little more information on the fault.

Mhpautos
Jan 14, 2012.
I did scan check again and the malfunction was only air massive sensor. Also, the rate of air pressured was 10.4 when the required which is needed is 8. So what do you think about the air massive sensor? And how can I check if it is just need something to be fixed or repaired and how can I repair the air massive sensor?
Thank you in advance

Tiny
Kais
Jan 19, 2012.
If the air massive sensor reading rate is 10.4 since the required is must be 8 means the air massive sensor is defected? Can I clean it rather than buy new one since it is expensive?
Thank you again

Tiny
Kais
Jan 19, 2012.
I am sorry the malfunction reading was mass air flow sensor
thank you

Tiny
Kais
Jan 19, 2012.
You can try cleaning, but this does not always work.

Mhpautos
Jan 20, 2012.
If the MAF sensor reading is 10.4 kg/ and the required is 8 kg/, what does it mean? Does it mean that the MAF does not work correctly and just cleaning? Or does it mean MAF is totally damaged and need new one?
Just to make sure is this rate of the air reading 10.4 is bad maf or it is just normal since the ideal rate is 8 kg/ ?
Thanks alot for your help

Tiny
Kais
Jan 21, 2012.
Page 1 of 3