Mechanics

RX330 PANEL BUTTON CORRUPTION

2005 Lexus RX 330 • 6 cylinder 2WD Automatic • 75,000 miles



A few days ago after starting my 05' RX330 I noticed that the Nav screen was blank. No "I accept" screen, nothing. Pressing a few of the A/C buttons I found that some did nothing at all, and some functioned, although their functions were very different than they should be. No Menus, no trip info, no climate control screens, just stereo control / station info screens that I never used to have at all.

It seemed as though that only the stereo was linked to the display now, which it never used to be. Then, pressing the "A/C off" button brought back the GPS map.

Then, after pressing the Climate Control button, my wife's side went to full cold A/C, and mine to full high heat with no apparent way to change it.

Panel buttons still wrong after pulling the battery cable in an attempt to clear memory. I had to reprogram the windows and sunroof, but no change to the panel button function corruption.

I was able to determine that the passenger side temp up button now controls the master temp down. It appears as though some software or firmware corruption has occurred within whatever module controls those functions.

While searching the forums I found the procedure for accessing the diagnostic nav menu which unbelievably has a test process for the panel buttons. Each one now has been assigned a different function than what it should be, and many of my old functions are not assigned to any button, but there doesn't appear to be any way to change them back.

I've also located a Lexus factory service manual which outlines the above test, and is complete with diagnostic flow charts, which documents absolutely nothing about what to do if the button assignments are incorrect.

Question is, what needs to be done to fix this problem, a reprogramming, or a replacement of whatever module must be suffering from early onset dementia?
Avatar
Reposado
July 15, 2011.




Look for trouble codes so start engine Press and Hold INFO button-see diagram-while holding Press Light Control switch: OFF-ON-OFF-ON-OFF-ON-OFF Diagnostic mode will start screen will display "System Check Mode"
Results will be displayed post that Info/codes

Docfixit
Jul 15, 2011.
Yea, I've done that. No fault codes at all. Not only that but the "info" button no longer works, it's now the "A/C auto" button. I can still enter diagnostics but have to do it from the check display screen using the "dest" button.
AD

Tiny
Reposado
Jul 15, 2011.
O.K. If can't self diagnose then scan tool needed but have one more way. Start engine Switch to "Display Check screen"From screen touch four corners in this sequence Upper Left-Lower left-Upper Left-Lower-Left Upper Left Lower Left "Service Check" screen wil be activated

Docfixit
Jul 15, 2011.
Yes, I've done that. There are no fault codes. All systems report that they check OK, except that the button functions are now wrong.

I guess my question is this: Is the Intelligent Tester used by the dealer capable of reprogramming these functions? I've been told that it has reprogramming capabilities, but not what those capabilities are.

Tiny
Reposado
Jul 15, 2011.
Yes dealer Trained Tech is best to resolve problem

Docfixit
Jul 15, 2011.

AD