Mechanics

STARTER NOT ENGAGING

2005 Jeep Liberty • 6 cylinder 4WD Automatic • 124,000 miles

2005 Jeep Liberty Renegade Edition Vehicle has started fine for years never an issue. Today started just fine no driving issues at all. Shut vehicle off came back out ten minutes later and the starter just would not engage. Dash lit up radio / heater came on but no engine kicking over not even engaging? Acted like this for twenty minutes just before I was calling for a tow, one last trie and started like a charm. Started sveral times after that fine then later in evening the same issue? Last night we wer -28 an d by noon it was 0 thats a 28 degree change in 12 hrs? At a loss never seen anything like this before.
Avatar
Danno38
November 26, 2010.




Check the starter, starter relay, transmission position switch and ignition switch assuming the battery and connections are good.


Tiny
Rasmataz
Nov 26, 2010.
Thanks those are things I considered. What is so bizarre is it started 5 times withing ten minutes fine. Then nothing? Will get battery checked first thing, if the amps are teetering on accepatble I assume the relay wont open. Thanks again. Once it started I had no power issues and drove around returning home.
Thanks again.

Dan


Tiny
Danno38
Nov 26, 2010.
Danno38--My 2005 Jeep Liberty has been doing the exact same thing that you describe. I've found no one else online that has the same issue. What did you end up finding out was wrong with it?

Kirsten
AD


Tiny
Wildcatgirl
Feb 17, 2012.
SOUNDS LIKE RASMATAZ JUST ABOUT COVERED ALL OF THE BASES

THE ONLY THING THAT WAS NOT MENTIONED WAS THE POSSIBILITY OF BEING INTERMITTENT.

NO ONE MENTIONED ACTUAL STARTER REMOVAL AND "FORMAL TESTING" AT MANY-A POPULAR AUTO PARTS STORE....USUALLY DONE FOR FREE!

SAME GOES FOR OTHER "EXPENDABLE/ INEXPENSIVE" PARTS THAT HAVE "SLAVED FOR YOU" FOR YEARS! (LIKE THE STARTER RELAY, EVEN THE STARTER'S BRUSHES) THESE PARTS MAY HIT 50 TIMES SEEMING JUST FINE, IN REALITY THE CONTACTS MAY BARELY BE COMPLETING THE CIRCUIT THOSE 50 TIMES....TRY 51 IN THE MIDDLE OF NO WHERE, MAY LEAVE YOU STRANDED!

THINGS LIKE THE ABOVE, AND EVEN MY THERMOSTAT, I REPLACE EVERY 2-5 YEARS....NEED IT OR NOT!

BEFORE YOU DO ANYTHING $$$ WISE, SEE IF YOU DO HAVE VOLTAGE REACHING WHERE IT SHOULD, WHEN THE KEY IS TURNED TO "ON" AND "START"

AS FAR AS CONNECTIONS---THIS IS HOW I GENERALLY SEE THEM--"NOT APPROACHED!".....SEE MY NOVEL LIKE CONTRIBUTION TO THIS POST!

http://www.2carpros.com/questions/2000-pontiac-sunfire-try-ignition-nothing-fires-totally-dead-won-t-start-need

PLEASE RETURN WITH A SMILE AND GOOD TIDINGS!

THE MEDIC


Tiny
CJ MEDEVAC
Feb 18, 2012.

AD