Mechanics

ISUZU ASCENDER FUSE PROBLEM

2005 Isuzu Ascender • 6 cylinder •

About 3 weeks ago I accidentally hooked jumper cables the the fuse box instead of the battery. Stupid I know but just a mistake. I blew the main fuse and was able to buy another at the dealership and replace it. After replacing the main fuse everything worked fine for about a week when the check engine light came on. The code said I had a problem with the smog pump. Now this morning my wife filled up the car with gas and now the gas gauge is going up and down like it dont know how much gas is in the tank. Could all this be a result of something I did or just a coinsidence? What should I do?
Avatar
Heelz76
April 5, 2011.



Let me have the EXACT trouble code and we shall see if we can come up with anything.

KHLow2008
Apr 5, 2011.
Sorry I dont remember what the code was. It has been a couple weeks ago.

Tiny
Heelz76
Apr 5, 2011.
Autozone and most major parts stores provides free scanning services. Whether the problem is coincidental ( which I believe is more likely) or due to the error, you still need to get the problem resolved and the trouble code is required to understand what is wrong and provide suggestions.

KHLow2008
Apr 5, 2011.
TYVM.I am going to have the vehicle put on a computer Thursday so I can see what is actually going on. Thx for the help and I will provide more when I have the info.

Tiny
Heelz76
Apr 5, 2011.
You're welcome. If you require any information, just post reply and I will get back to you.

Have a nice day.

KHLow2008
Apr 5, 2011.