Mechanics

CHECK ENGINE LIGHT ON FOR ALMOST A YEAR NOW! PLEASE HELP!!!

2005 Ford Expedition • 14,200 miles

I have a 2005 Ford Expedition. My check engine light has been on for almost a year now. The code it throws is the O2 sensor, bank 2. I have had the sensor replaced 3 times. I've also had the spark plugs and coils replaced. Light is still on. Trucks performance is decreasing. Exhaust recently started smelling bad. Truck will shake at idle and sounds like its going to cut out. My friend (who is an airplane mechanic, but also knows a great deal about cars) said he thinks it's the cat converter. He's never looked at my truck but feels that's what it is. I've brought my truck into two different places, one being a Meineke, and they both said that the "code" says its the O2 sensor and that as far as they could tell, the cat was fine. WELL. CLEARLY SOMETHING IS CAUSING THE O2 SENSOR TO CONTINUE TO FAIL! Any ideas. Please help!
Avatar
MAIDENMAINE
August 30, 2012.




The issue is the o2 is not bad. It is something else. What are all the codes? It sounds like it is missfiring which may be plugs and coils?

A full year? Never, never let the light be on without getting the code repaired as it will cause other issues like this down the road.

Roy

ASEMaster6371
Aug 30, 2012.
[quote] WELL. CLEARLY SOMETHING IS CAUSING THE O2 SENSOR TO CONTINUE TO FAIL! [/Quote]

No, not hardly. You're just throwing good sensors away. The code number does not identify a failed part. T merely identifies a specific situation that needs further diagnosis to determine the actual cause. Post the exact code numbers.
AD

Wrenchtech
Aug 30, 2012.

AD